Updates to the MetaTrader 4 Platform

We have been notified by MetaQuotes Software Corp. that as of 1 October 2017 (Sunday), support for Windows XP, Windows 2003 and Windows Vista will be discontinued for the MetaTrader 4 platform. As potential hardware capabilities can no longer be recognised, these operating systems are considered to be outdated.

MetaQuotes has stated that Windows 7 is the minimum required operating system version for running MetaTrader 4. However, using the 64-bit versions of Windows 10 is strongly recommended.

Older versions of MetaTrader 4 will continue to work on Windows XP, Windows 2003 and Windows Vista. After 1 October 2017 (Sunday), updates will no longer be received and installers will not run on these operating systems. Without having your MetaTrader 4 up to date, you may not be able to execute trades or have guaranteed stability.

As always, feel free to contact info@darwinex.com if you have any questions or need a solution for this change!

0 replies

Leave a Reply

Want to join the discussion?
Feel free to contribute!

Leave a Reply

Your email address will not be published. Required fields are marked *